Главная страница \ Разработки \ Программы \ Обновление Denwer (Apache 2.4, PHP 7, MySQL 5.7)

Обновление Denwer (Apache 2.4, PHP 7, MySQL 5.7)

Denwer Неофициальный апдейт, Apache 2.4 PHP7 MySQL 5.7Появилась необходимость быстро развернуть локальный сервер со свежими версиями ПО (для всякого рода Joomla, WordPress и прочих Drupal), как подсказывала память - есть отличное решение Денвер. Но оказалось, что автор уже долгое время не поддерживает проект и не выпускает обновления для него. Простым же путём (скачиванием и заменой старых дистрибутивов на новые) решить задачу не получилось. Т.к. был выбор или настраивать систему с нуля или попытаться обновить существующую систему решено было обновить существующую. Для этого пришлось интегрировать в сборку VC2015 Redistributable, а также, заодно, оставить многие нужные библиотеки. С сегодняшними скоростями подключения к сети интернет и размерами флешек/жёстких дисков проблема нехватки места уже так остро не стоит.

К сожалению, пришлось практически полностью перекроить существующий пакет Денвера, поэтому фактически установка и настройка происходят по принципу полной замены базовой установки.

В текущей сборке представлено следующее ПО:
Apache 2.4.23 (со всеми модулями)
PHP 7.0.10 (со всеми расширениями + xdebug)
MySQL 5.7.15
PhpMyAdmin 4.6.4

Скачать обновление Denwer 3

Важно!

В связи с участившимися вопросами считаю необходимым дать пояснения.

Данное обновление содержит новую версию PHP 7 в которой произошли значительные изменения в составе предоставляемых возможностей.

Наиболее важно для многих - с данной версии PHP стали отсутствовать некоторые функции, особенно обратите внимание на отсутствие mysql_*, mssql_*.

Поэтому перед обновлением крайне рекомендую ознакомиться с разделом о миграции с PHP 5.6.* на PHP 7.0.*.

Видеоинструкция по установке обновлённого пакета

Вопросы? Предложения?

Странник [01.01.2017]
А зачем мучать denwer если есть готовый Xampp, который ещё и мультиплатформенный?
Вячеслав [26.12.2016]
Спасибо. Помгло
Landgraph [26.12.2016]
2Роман: а зачем Вам denwer.exe? За что он должен отвечать?

2Anton: печально, конечно... но народ жаждет подробностей!
Anton [25.12.2016]
Говно полное, не работает, что не делай.
Евгений [21.12.2016]
Огромное спасибо за обновление!! давно искал Денвер с PHP7

Хотел узнать, php7 поддерживает PDO драйвер для работы с MySQLi ???
Роман [07.12.2016]
Нет denwer.exe в архиве!!!!!
Роман [07.12.2016]
Скачивается зип архив со всеми директориями , но без установочного файла.И зачем это скачивать без установочного файла вообще?
Елена [10.11.2016]
Спасибо огромное! Установила и все работает :) Magento без PHP7 не работало.
Landgraph [10.11.2016]
Рад, что смог помочь :)
Алекс [05.11.2016]
:) Спасибо! Это то что я долго искал. В серваках, корорые юзал до этого, композитор или вообще не работал, или в полуручном режиме. Снес всю эту гадость без сожалений. Только что за 10 мин загрузил десяток пакетов, впервые без заморочек. Я счастлив!
[1]  [2]  [3]  [4]  [5
Powered by Elise